Excel-Kurse – Excel-Schulung und Beratung – Excel professionell lernen

Excel-Funktionen und Formeln

Excel kennt eine Vielzahl von Funktionen. Der normale Nutzer benötigt jedoch gerade einmal 5 bis 10% des Funktionsumfangs von Excel. Die Excel-Funktionen können in komplexen Formeln stehen und für die unterschiedlichsten Einsatzgebiete genutzt werden. Die Funktionen machen Excel zu einem sehr leistungsstarken Tabellenkalkulationsprogramm.


Der Funktionsassistent von Excel

Der Funktionsassistent kann beim Erstellen der Excel-Funktionen sehr hilfreich sein. Der Funktionsassistent ist für Anfänger sehr nützlich. Aber auch fortgeschrittene Excel-Nutzer können durch den Einsatz des Funktionsassistenten syntaktische Fehler vermeiden. Leicht vergisst man ein Semikolon. Bei komplexen Formeln ist nicht so einfach, den Fehler schnell zu finden. In meinen Excel-Schulungen sehe ich das immer wieder. Häufig geht es sogar schneller, wenn man die Formel noch mal komplett neu eingibt.


Unterschied zwischen Formeln und Funktionen

Bevor ich Ihnen die wichtigsten Excel-Funktionen vorstelle, werde ich kurz den Unterschied zwischen Formeln und Funktionen erläutern. Die Formeln müssen Sie in Excel selbst erstellen. Diese beginnen immer mit einem Gleichheitszeichen. In den Formeln können die vorgefertigten Excel-Funktionen genutzt werden. Fortgeschrittene Excel-Nutzer können auch eigene Funktionen mit VBA selbst erstellen. Auch die Excel-Funktionen beginnen mit einem Gleichheitszeichen, gefolgt vom Funktionsnamen, dem meistens ein oder mehrere Argumente in Klammern folgen. Die Argumente sind durch ein Semikolon getrennt.

Wenn Sie in eine Zelle =MITTELWERT(A2:B8) schreiben, dann rufen Sie die Funktion MITTELWERT auf. Berechnet wird dann der Mittelwert aller Zellen des Bereiches von A2 bis B8. Der Doppelpunkt zwischen A2 bis B8 weist darauf hin, dass es sich um einen Bereich handelt.


Häufig genutzte Excel-Funktionen

Die Funktionen SUMME(), MITTELWERT(), MAX(), MIN() und ANZAHL() können direkt durch einen Klick auf den Pfeil neben dem Summensymbol geöffnet werden.

Zu unterscheiden sind die Funktionen ANZAHL() und ANZAHL2(). Die Excel-Funktion ANZAHL() zählt die Zellen in denen Zahlen stehen. ANZAHL2() hingegen zählt alle „nicht leeren Zellen" im Bereich. Beachten Sie bitte, dass auch eine Zelle in der nur ein Leerzeichen steht nicht leer ist.

Diese Informationen finden Sie auch im Funktionsassistenten. Sie sehen schon wie hilfreich dieser sein kann.


Excel-Funktion: RUNDEN()

Wer mit Buchführung zu tun hat oder Rechnungen mit Mehrwertsteuer erstellen will sollte die Excel-Funktion RUNDEN() kennen. Denn wenn eine Excel-Formel ein berechnetes Ergebnis nutzt, rechnet Excel normalerweise mit den genauen Werten weiter (auch wenn das Währungsformat angegeben ist). Dies ist in den meisten Fällen ja auch gewünscht. Mit RUNDEN() wird das Ergebnis kaufmännisch gerundet. Die Zahl der Nachkommastellen kann angegeben werden.

Die Funktionen AUFRUNDEN() und ABRUNDEN() werden bei der praktischen Arbeit mit Excel seltener genutzt.


Excel-Funktion: WENN()

Die Wenn-Funktion sollte jeder Excel-Anwender kennen. Diese bietet eine einfache Möglichkeit, Alternativentscheidungen zu automatisieren. So können z.B. alle Kunden, die einen Mindestumsatz von 100.000 € erzielen, automatisch als VIP gekennzeichnet werden.

Die Wenn-Funktion hat folgende Syntax: =WENN(Prüfung;Dann;Sonst). Im ersten Argument erfolgt die Prüfung. Wenn die Prüfung WAHR ergibt kommt der Dann-Ast zum Tragen, falls die Prüfung FALSCH ergibt wird der Sonst-Ast ausgeführt.

--> =WENN(Prüfung;Dann;Sonst) <-- Die Wenn-Funktion ist die wichtigste Logikfunktion. Im Prüf-Element der Wenn-Funktion können zusätzliche Logikfunktionen zum Einsatz kommen. Hier sind die UND-Funktion und die ODER-Funktion sehr hilfreich.

Unser Beispiel kann nun wie folgt umgesetzt werden. Wenn in der Zelle A2 der Umsatz steht, ergibt sich die folgende Funktion: =WENN(A2>=100000;"VIP";"").

Im Dann- und Sonst-Ast können auch Berechnungen durchgeführt werden. In der Wenn-Funktion können weitere Funktionen stehen. Die Prüfung lässt sich gut mit anderen Logikfunktionen kombinieren. Außerdem können Wenn-Funktionen ineinander verschachtelt werden. So können sehr komplexe Formeln entstehen.

Wer sich näher mit der verschachtelten Wenn-Funktion beschäftigen möchte, der sollte sich mein Video zur ABC-Analyse mit Excel anschauen.


Excel-Funktion: SVERWEIS()

Der SVERWEIS sucht anhand eines Suchkriteriums in der ersten Spalte einer Datenbasis – auch Matrix genannt. Die Zeile in der das Suchkriterium gefunden wird und der Spaltenindex bestimmen dann den zurückgegebenen Wert. Der SVERWEIS hat folgende Syntax: =SVERWEIS(Suchkriterium;Matrix;Spaltenindex;Bereich_Verweis)

Beispiel: =SVERWEIS(D2;A2:B8;2) In der Zelle D2 steht das Suchkriterium nach dem in der ersten Spalte der Matrix A2:B8 gesucht wird. Zurückgegeben wird der entsprechende Wert aus der 2. Spalte der Matrix.

Die Spalten der Matrix und nicht die des Arbeitsblattes sind dabei entscheidend. Wenn der genaue Wert nicht gefunden wird, wird der größte Wert zurückgegeben, der kleiner als das Suchkriterium ist.

Die Werte in der ersten Spalte der Matrix müssen in aufsteigender Sortierreihenfolge geordnet sein, andernfalls gibt SVERWEIS möglicherweise nicht den richtigen Wert zurück.

Wenn die Werte in der ersten Spalte der Matrix nicht in aufsteigender Sortierreihenfolge geordnet sind, muss die Funktion wie folgt geändert werden: =SVERWEIS(D2;A2:B8;2;FALSCH).

Die Formel hat den gleichen Aufbau. Der Unterschied liegt darin, dass im Bereich_Verweis "FALSCH" steht. Es wird immer nach dem genauen Wert gesucht. Wenn dieser nicht gefunden wird, wird der Fehlerwert "#NV" zurückgegeben.

Falls Sie Artikel anhand einer Artikelnummer aus einer Datenbank heraussuchen wollen muss im Bereich_Verweis "FALSCH" stehen, um Tippfehler zu vermeiden. Denn sonst könnte es passieren, dass jemand eine Artikelnummer eingibt, die es gar nicht gibt und damit eine fehlerhafte Lieferung an einen Kunden auslöst.


Der richtige Einsatz der Excel-Funktionen ist entscheidend

Die reine Kenntnis der Excel-Funktionen reicht jedoch nicht aus. Die praktische Umsetzung und ein strukturierter Formelaufbau sind entscheidend. In meinen Excel-Schulungen lernen Sie mit Hilfe von vielfältigen zielorientierten Übungen die Tabellenkalkulation Excel effizienter zu nutzen.

Das ist eine Investition in Ihre Zukunft, mit der Sie viel Zeit und damit Geld sparen können.